您的位置:首页 > 其它

PAT (Advanced Level) Practise 1088 Rational Arithmetic (20)

2017-07-04 14:46 453 查看


1088. Rational Arithmetic (20)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of
the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k
a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It
is guaranteed that all the output integers are in the range of long int.
Sample Input 1:
2/3 -4/2

Sample Output 1:
2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:
5/3 0/6

Sample Output 2:
1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf


题意:给你两个分数,写出两个分数乘除加减的式子

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

LL gcd(LL x, LL y)
{
if (x > y) swap(x, y);
while (y%x)
{
LL k = y%x;
y = x;
x = k;
}
return x;
}

void f(LL x, LL y)
{
if (x == 0) {printf("0"); return ;}
LL xx = abs(x);
LL k = gcd(xx, y);
x /= k, y /= k;
if (x%y == 0)
{
if (x / y < 0) printf("(%lld)", x / y);
else printf("%lld", x / y);
}
else
{
if (abs(x) < y)
{
if (x < 0) printf("(%lld/%lld)", x, y);
else printf("%lld/%lld", x, y);
}
else
{
if (x < 0) printf("(%lld %lld/%lld)", (LL)(x / y), abs(x) % y, y);
else printf("%lld %lld/%lld", x / y, x % y, y);
}
}
}

int main()
{
LL a[3], b[3];
while (~scanf("%lld/%lld %lld/%lld", &a[1], &b[1], &a[2], &b[2]))
{
LL ans1=0, ans2=1;
for (int i = 1; i <= 2; i++)
{
LL k = gcd(ans2, b[i]);
ans2 = ans2*b[i] / k;
}
for (int i = 1; i <= 2; i++) ans1 += ans2 / b[i] * a[i];
f(a[1], b[1]); printf(" + "); f(a[2],b[2]); printf(" = ");
f(ans1, ans2); printf("\n");
ans1 = ans2/b[1]*a[1]-ans2/b[2]*a[2];
f(a[1], b[1]); printf(" - "); f(a[2], b[2]); printf(" = "); f(ans1, ans2); printf("\n");
f(a[1], b[1]); printf(" * "); f(a[2], b[2]); printf(" = "); f(a[1]*a[2], b[1]*b[2]); printf("\n");
if (!a[2])
{
f(a[1], b[1]); printf(" / "); printf("0 = Inf\n");
}
else
{
ans1 = a[1] * b[2]*a[2]/abs(a[2]);
ans2 = b[1] * abs(a[2]);
f(a[1], b[1]); printf(" / "); f(a[2], b[2]); printf(" = "); f(ans1, ans2); printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: