您的位置:首页 > 其它

PAT甲级 1002. A+B for Polynomials (25)

2017-07-04 08:22 645 查看


1002. A+B for Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


题意:将多项式A,B相加并且输出。

#include <bits/stdc++.h>
using namespace std;

double cnt[50000];

int main()
{
int Max=-1;
int a;
cin>>a;
for(int i=1;i<=a;i++)
{
double b;
int c;
cin>>c>>b;
cnt[c]+=b;
Max=max(Max,c);
}
cin>>a;
for(int i=1;i<=a;i++)
{
double b;
int c;
cin>>c>>b;
cnt[c]+=b;
Max=max(Max,c);
}
int tot=0;
for(int i=Max;i>=0;i--)
{
if(cnt[i]!=0) tot++;
}
cout<<tot;
for(int i=Max;i>=0;i--)
{
if(cnt[i]!=0)
{
printf(" %d %.1lf",i,cnt[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: