您的位置:首页 > 其它

PAT甲级 1120. Friend Numbers (20)

2017-07-03 23:25 387 查看


1120. Friend Numbers (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count
the number of different friend ID's among them. Note: a number is considered a friend of itself.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the
end of the line.
Sample Input:
8
123 899 51 998 27 33 36 12

Sample Output:
4
3 6 9 26


————————————————————————————————

题目的意思是问把n个数,每个数每位加起来的和作为一个值,把不同的值从小到大输出

思路:把每个数的和扔到set里,输出

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>
using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int main()
{
int n,x;
scanf("%d",&n);
set<int>s;
for(int i=0;i<n;i++)
{
scanf("%d",&x);
int sum=0;
while(x>0)
{
sum+=x%10;
x/=10;
}
s.insert(sum);
}
printf("%d\n",s.size());
set<int>::iterator it=s.begin();
int q=0;
for(;it!=s.end();it++)
{
if(q++)
printf(" ");
printf("%d",*it);
}
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: