您的位置:首页 > 其它

HDU 1258 Sum It Up

2017-07-03 12:31 281 查看


Sum It Up

Problem Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number
can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

 

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer
less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

 

Output

For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated
in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number
must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

 

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

 

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

 题意:输入两个数,t,表示和,然后输入n,接着输入n个数,求在n个数中,选取其中几个数,使得他们的和为t,并且以相加的形式输出这几个数。

分析:这是一道DFS的题目,我的想法是从cur=0开始遍历,每次从cur+1开始搜索,需要注意的是在每一次递归中,相同的数只能使用一次,这样可以避免多次输出相同的解,因此需要标记当前使用的数值,用另一个数组来记录当前所使用的数值,当sum=t的时候,按照格式输出每一位使用的数~
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int flag;
int a[2000];
int id[2000];
int b[2000];
int sum,n;
void dfs(int s,int cur,int count1)
{
if(s==sum)
{
flag=true;
for(int i=1;i<=count1;i++)
{
if(i!=count1)
printf("%d+",b[i]);
else
printf("%d\n",b[i]);
}
}
else
{
int t=-1;
for(int i=cur+1;i<=n;i++)
{
if(t!=a[i])
{
t=a[i];
b[count1+1]=a[i];
dfs(s+a[i],i,count1+1);
}
}
}
}
int main()
{
while(~scanf("%d%d",&sum,&n)&&sum&&n)
{
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
printf("Sums of %d:\n",sum);
flag=false;
memset(id,0,sizeof(id));
dfs(0,0,0);
if(flag==false)
printf("NONE\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU DFS