您的位置:首页 > Web前端

【USACO15FEB】审查(黄金)Censoring (Gold)

2017-07-02 11:55 260 查看

题目描述

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

FJ has taken all of the text from the magazine to create the string S of length at most 10^5 characters. He has a list of censored words t_1 ... t_N that he wishes to delete from S. To do so Farmer John finds the earliest occurrence of a censored word in S (having the earliest start index) and removes that instance of the word from S. He then repeats the process again, deleting the earliest occurrence of a censored word from S, repeating until there are no more occurrences of censored words in S. Note that the deletion of one censored word might create a new occurrence of a censored word that didn't exist before.

Farmer John notes that the censored words have the property that no censored word appears as a substring of another censored word. In particular this means the censored word with earliest index in S is uniquely defined.

Please help FJ determine the final contents of S after censoring is complete.

FJ把杂志上所有的文章摘抄了下来并把它变成了一个长度不超过10^5的字符串S。他有一个包含n个单词的列表,列表里的n个单词记为t_1...t_N。他希望从S中删除这些单词。

FJ每次在S中找到最早出现的列表中的单词(最早出现指该单词的开始位置最小),然后从S中删除这个单词。他重复这个操作直到S中没有列表里的单词为止。注意删除一个单词后可能会导致S中出现另一个列表中的单词

FJ注意到列表中的单词不会出现一个单词是另一个单词子串的情况,这意味着每个列表中的单词在S中出现的开始位置是互不相同的

请帮助FJ完成这些操作并输出最后的S

输入输出格式

输入格式:

The first line will contain S.

The second line will contain N, the number of censored words. The
next N lines contain the strings t_1 ... t_N. Each string will contain
lower-case alphabet characters (in the range a..z), and the combined
lengths of all these strings will be at most 10^5.

输出格式:

The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.

输入输出样例

输入样例#1:

begintheescapexecutionatthebreakofdawn
2
escape
execution


输出样例#1:

beginthatthebreakofdawn


题解:
将n个单词建Trie,开一个栈记录答案和走的顺序,然后走到有标记的地方就直接把栈的top减dis(dis为该节点到root的距离)


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
const int LL=100005;
char s[LL],h[LL];
struct node
{
int next[27],cnt,dis;
}a[LL];
int fail[LL],num=0,root=0;
void Clear()
{
a[num].cnt=0;
a[num].dis=0;
for(int i=0;i<=26;i++)a[num].next[i]=0;
}
void add()
{
scanf("%s",h);
int p=root;
for(int i=0,ls=strlen(h);i<ls;i++)
{
if(a[p].next[h[i]-'a'])a[a[p].next[h[i]-'a']].dis=a[p].dis+1,p=a[p].next[h[i]-'a'];
else
{
a[p].next[h[i]-'a']=++num;
Clear();
a[num].dis=a[p].dis+1;
p=num;
}
}
a[p].cnt++;
}
void getfail()
{
queue<int>q;
q.push(root);
int p,v,to;
while(!q.empty())
{
p=q.front();q.pop();
for(int i=0;i<=26;i++)
{
if(!a[p].next[i])
{
if(a[fail[p]].next[i])a[p].next[i]=a[fail[p]].next[i];
continue;
}
v=fail[p];
while(v)
{
if(a[v].next[i])break;
v=fail[v];
}
to=a[p].next[i];
if(a[v].next[i] && a[v].next[i]!=a[p].next[i])fail[to]=a[v].next[i];
q.push(to);
}
}
}
int st[LL];char ans[LL];int top=0;
void pf()
{
int u;
int p=root;
st[++top]=root;
for(int i=0,ls=strlen(s);i<ls;i++)
{
u=s[i]-'a';
while(!a[p].next[u] && p)p=fail[p];
p=a[p].next[u];
st[++top]=p;ans[top]=s[i];
if(a[p].cnt)
{
top-=a[p].dis;
p=st[top];
}
}
}
int main()
{
//freopen("pp.in","r",stdin);
Clear();
scanf("%s",s);
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)add();
getfail();
pf();
for(int i=2;i<=top;i++)printf("%c",ans[i]);
printf("\n");
return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: