您的位置:首页 > 其它

UVALive4167 HDU2700 Parity【水题】

2017-07-01 00:34 274 查看

Parity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4842    Accepted Submission(s): 3635

[align=left]Problem Description[/align]
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number
of

0's does not affect the parity of a bit string.
Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a
lowercase letter 'o'.

Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity
(if the letter was 'o').
Sample Input

101e
010010o
1e
000e
110100101o
#

Sample Output

1010
0100101
11
0000
1101001010

Source
2008 Mid-Central USA

Regionals 2008 >> North
America - Mid-Central USA


问题链接UVALive4167 HDU2700 Parity

题意简述:参见上文。

问题分析:这是一个计算奇偶校验码问题。
程序说明

  由于函数gets()不被推荐使用(容易造成存储越界访问),所有使用函数fgets()来读入一行字符串。
  使用函数fgets()时,需要考虑字符串末尾的'\n'和'\0',关系大数组的大小。所以符号常量N不能过小,不然会WA。

题记:函数gets()还是可以用的,需要谨慎使用。最好是使用函数fgets()。

AC的C语言程序如下:

/* UVALive4167 HDU2700 Parity */

#include <stdio.h>

#define N 32 + 2
char s[N+1];

int main(void)
{
while(fgets(s, N, stdin) != NULL) {
if(s[0] == '#')
break;

int i = 0, cnt = 0;
while(s[i] != '\n' && s[i]) {
if(s[i] == '1')
cnt++;
i++;
}

i--;
if(s[i] == 'e') {
if(cnt % 2 == 0)
s[i++] = '0';
else
s[i++] = '1';
} else if(s[i] == 'o') {
if(cnt % 2 == 0)
s[i++] = '1';
else
s[i++] = '0';
}

s[i] = '\0';
printf("%s\n", s);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: