您的位置:首页 > 其它

HDU 3711 Binary Number【水题】【bitset】

2017-06-30 17:31 281 查看


Binary Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2714    Accepted Submission(s): 1573


Problem Description

For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find
an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.

 

Input

The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then
follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

 

Output

For each test case you s
4000
hould output n lines, each of which contains the result for each query in a single line.

 

Sample Input

2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353

 

Sample Output

1
2
1
1
1
9999
0

 

Author

CAO, Peng

 

Source

2010 Asia Chengdu Regional Contest

给n个数和m个数,判断对于m哪个n与它相差2进制数最少

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <bitset>
#include <queue>
#define INF 0x3f3f3f3f
using namespace std;

const int maxn = 110;
const int n = 100;

bitset<20> a[maxn], b[maxn];
int num[maxn];

int f(int p, int q)
{
int ans = 0;
for (int i = 0; i < 20; i++)
{
if (a[p][i] != b[q][i]) ans++;
}
return ans;
}

int main()
{
int t;
scanf("%d", &t);
while (t--)
{
int n, m;
scanf("%d%d", &n, &m);
for (int i = 0; i < n; i++)
{
scanf("%d", num + i);
a[i] = num[i];
}
for (int j = 0; j < m; j++)
{
int p;
scanf("%d", &p);
b[j] = p;
}
for (int i = 0; i < m; i++)
{
int ans = INF, val = -1;
for (int j = 0; j < n; j++)
{
int temp = f(j, i);
if (temp < ans)
{
ans = temp;
val = num[j];
}
else if (temp == ans && (val == -1 || num[j] < val))
{
val = num[j];
}
}
printf("%d\n", val);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: