您的位置:首页 > 其它

PAT (Advanced Level) Practise 1103 Integer Factorization (30)

2017-06-30 13:46 399 查看


1103. Integer Factorization (30)

时间限制

1200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 +
12, or 112 + 62 + 22 + 22 + 22, or more. You must output the
one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than
{ b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".
Sample Input 1:
169 5 2

Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:
169 167 3

Sample Output 2:
Impossible


题意:给你一个n,k,p,让你找出一个有k个元素的序列,它们p次方的和等于n,若有多个,输出元素和最大的,若仍有多个,输出序列最大的

解题思路:dfs+剪枝

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF = 0x7FFFFFFF;

int n,k,p,ans[500],flag,a[500],ma,b[500];

int mypow(int x,int k)
{
int ans=1;
while(k)
{
if(k&1) ans*=x;
k>>=1;
x*=x;
}
return ans;
}

void dfs(int x,int sum,int pos)
{
if(sum==n&&k==x)
{
int sum1=0;
for(int i=0;i<k;i++) sum1+=a[i],b[i]=a[i];
sort(b,b+k,greater<int>());
int p=0;
while(b[p]==ans[p]&&p<k)p++;
if((b[p]>ans[p]&&p<k&&sum1==ma)||sum1>ma)
{
ma=sum1;
for(int i=0;i<k;i++) ans[i]=b[i];
}
flag=1;
return ;
}
int xx=mypow(pos,p);
if(sum+(k-x)*xx>n||x>=k||sum>=n) return ;
for(int i=pos; i<=20; i++)
{
a[x]=i;
dfs(x+1,sum+mypow(i,p),i);
}
}

int main()
{
while(~scanf("%d%d%d",&n,&k,&p))
{
flag=0;
ma=0;
dfs(0,0,1);
if(!flag) {printf("Impossible\n");continue;}
printf("%d = %d^%d",n,ans[0],p);
for(int i=1; i<k; i++)
printf(" + %d^%d",ans[i],p);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: