您的位置:首页 > 其它

ZOJ Problem Set - 1292

2017-06-30 12:39 323 查看
Integer Inquiry
Time Limit:
2 Seconds      Memory Limit: 65536 KB
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input


1

123456789012345678901234567890

123456789012345678901234567890

123456789012345678901234567890

0


Sample Output


370370367037037036703703703670

解题报告:

题意就是几个很大的数相加,这时想到用string来做,但是想了半天也不知道怎么写,我还是太水了


看了下大佬的解题过程,有些地方没看懂,智商捉急啊!!!

#include<stdio.h>
#include<string>
#include<iostream>
using namespace std;
//高精度相加模板
string add(string str1,string str2)//高精度加法,两个正数相加
{
string str;

int len1=str1.length();
int len2=str2.length();
if(len1<len2) //前面补0,弄成两个数长度相同
{
for(int i=1;i<=len2-len1;i++)
str1="0"+str1;
}
else
{
for(int i=1;i<=len1-len2;i++)
str2="0"+str2;
}
len1=str1.length();
int cf=0;
int temp;
for(int i=len1-1;i>=0;i--) //从第一位开始相加
{
temp=str1[i]-'0'+str2[i]-'0'+cf;
cf=temp/10; //低位相加,大于10进位
temp%=10; //低位相加,大于10进位,个位数留下来
str=char(temp+'0')+str; //char(temp+'0')不懂
}
if(cf!=0) str=char(cf+'0')+str; //不为0最高位进1
return str;
}

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
string sum="0";
string str1;
while(cin>>str1)
{
if(str1=="0")break;
sum=add(sum,str1);
}
cout<<sum<<endl;
if(T>0)cout<<endl;
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: