您的位置:首页 > 其它

zoj 3123 尺取法

2017-06-30 10:26 267 查看
这个也是训练赛上的一个题,当时一看1e9就没有直接爆,记得做过这个题,的确是白书的上一个原题,

这个题需要注意的就是题目的理解,暴力的时候,左右一个标尺,先从右开始,然后逐渐减左标尺上对应的位置。这样处理应该就可以

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write
a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second
line of the test case, separated by intervals. The input will finish with the end of file.

<b< dd="">

Output

For each the case the program has to print the result on separate line of the output file.If no answer, print 0.

<b< dd="">

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

<b< dd="">

Sample Output

2
3

#include<iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
using namespace std;
//const int INF = 1e9;
const int INF = 0x3f3f3f3f;
const int maxn = 100000+10;
int ss[maxn];
int n, s;
int left,right;

int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%d%d", &n, &s);
for(int i = 0; i < n; ++i)
scanf("%d", &ss[i]);
int left = 0,right = 0;
int sum = 0, cur = INF;
while(1)
{
while(right < n && sum < s)
{
sum += ss[right];
right++;
}
if(sum < s)
break;
cur = min(cur, right-left);
sum -= ss[left];
left++;
}
if(cur == INF)
cout<<0<<endl;
else
cout<<cur<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: