您的位置:首页 > 其它

九度OJ-题目1468-Sharing-链表

2017-06-27 20:45 288 查看

题目描述:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.



Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).

输入:

For each case, the first line contains two addresses of nodes and a positive N (<= 10^5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

输出:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.

样例输入:

11111 22222 9

67890 i 00002

00010 a 12345

00003 g -1

12345 D 67890

00002 n 00003

22222 B 23456

11111 L 00001

23456 e 67890

00001 o 00010

00001 00002 4

00001 a 10001

10001 s -1

00002 a 10002

10002 t -1

样例输出:

67890

-1

来源:

2012年浙江大学计算机及软件工程研究生机试真题

思路:

思路:

题目要求输出两个链表的第一个交叉的字符的地址,我们可以不用搞链表的结构,直接把出现在第一个链表的字符标记出来(不需要真的搞个链表),然后遍历第二个链表,如果第二个字符串中的字符在第一个链表中出现了,就直接输出。否则,输出-1。

补充:这个题在pat练习题中也出现了:https://www.patest.cn/contests/pat-a-practise,属于中等难度题。pat里的题很多有关DS的,而且会给出测试点, 有需要的可以练练。

#include<bits/stdc++.h>
#define maxn  100001
using namespace std;

int rnode[maxn];
int node[maxn];
int main(){

int s1,s2,n,t1,t2;

while(~scanf("%d %d %d",&s1,&s2,&n)){
memset(node,0,sizeof(node));
memset(rnode,0,sizeof(rnode));
int t1,t2;
char c;
for(int i = 0;i < n;i++){
scanf("%d %c %d",&t1,&c,&t2);
node[t1] = t2;
}
while(s1 != -1){
rnode[s1] = 1;//标记第一个链表中出现的字符
s1 = node[s1];
}
bool find = false;
while(s2 != -1){
if(rnode[s2] == 1){
printf("%.5d\n",s2);//如果不加这个.就会输出"    0"而不是"00000"
find = true;
break;
}else{
s2 = node[s2];
}
}
if(!find){
printf("-1\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息