您的位置:首页 > 其它

POJ 2456 Aggressive cows【二分:最大化最小值】

2017-06-26 15:51 501 查看
Aggressive cows

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14220 Accepted: 6887
Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them
is as large as possible. What is the largest minimum distance?
Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output

* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9

Sample Output
3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.
Source

USACO 2005 February Gold

Point:

1.区间为[lb,ub)前闭后开

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b)  memset(a,b,sizeof(a))
const int M=1e5+10;
const int inf=0x3f3f3f3f;
const int mod=1e9+7;
int a[M];
int i,j,k,n,m;

bool check(int mid)
{
int last=0;
for(int i=1;i<k;i++){
int cur=last+1;
while(cur<n&&(a[cur]-a[last])<mid)cur++;
if(cur==n)return false;
last=cur;
}
return true;
}

int main()
{
while(~scanf("%d%d",&n,&k)){
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
int lb=0,ub=1000000000;
while(ub-lb>1){
int mid=(lb+ub)/2;
if(check(mid))lb=mid;
else ub=mid;
}
printf("%d\n",lb);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: