您的位置:首页 > 其它

hdu 6027 水题 注意全程取模,全程long long

2017-06-25 22:03 393 查看
题目:


Easy Summation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 969    Accepted Submission(s): 391


Problem Description

You are encountered with a traditional problem concerning the sums of powers.

Given two integers n and k.
Let f(i)=ik,
please evaluate the sum f(1)+f(2)+...+f(n).
The problem is simple as it looks, apart from the value of n in
this question is quite large.

Can you figure the answer out? Since the answer may be too large, please output the answer modulo 109+7.

 

Input

The first line of the input contains an integer T(1≤T≤20),
denoting the number of test cases.

Each of the following T lines
contains two integers n(1≤n≤10000) and k(0≤k≤5).

 

Output

For each test case, print a single line containing an integer modulo 109+7.

 

Sample Input

3
2 5
4 2
4 1

 

Sample Output

33
30
10

代码:

#include<stdio.h>
#include<iostream>
using namespace std;
const int maxn=1e4+10;
const int mod=1e9+7;

int main(){
long long t,n,k;
scanf("%lld",&t);
long long ans;
while(t--){
scanf("%lld%lld",&n,&k);
ans=0;
for(long long i=1;i<=n;++i){
long long tmp=1;
for(long long j=1;j<=k;++j) tmp=tmp*i%mod;//这里没注意到取模 WA了两发
ans+=tmp;
ans%=mod;
}
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: