您的位置:首页 > 其它

HDU 5113--Black And White(搜索+剪枝)

2017-06-25 20:47 183 查看
题目链接

[align=left]Problem Description[/align]
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly ci cells.

Matt hopes you can tell him a possible coloring.

[align=left]Input[/align]
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers ci (ci > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c1 + c2 + · · · + cK = N × M .

[align=left]Output[/align]
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1).

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.

[align=left]Sample Input[/align]

4

1 5 2

4 1

3 3 4
1 2 2 4
2 3 3

2 2 2
3 2 3

2 2 2

[align=left]Sample Output[/align]

Case #1: NO
Case #2: YES
4 3 4
2 1 2
4 3 4
Case #3:
YES
1 2 3
2 3 1
Case #4:
YES
1 2
2 3
3 1

题意:有一个N*M的方格板,现在要在上面的每个方格上涂颜色,有K种颜色,每种颜色分别涂c[1]次、c[2]次……c[K]次,c[1]+c[2]+……+c[K]=N*M

要求每个方格的颜色与其上下左右均不同,如果可以输出YES,并且输出其中的一种涂法,如果不行,输出NO;

思路:暴力搜索,但是这样会超时,可以在搜索中加入剪枝:对于剩余的方格数res,以及当前剩余的颜色可涂数必须满足(res+1)/2>=c[i]

否则在当前情况下继续向下搜得不到正确涂法;

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int N,K,M;
int c[30];
int mp[10][10];

int check(int x,int y,int k)
{
int f=1;
if(mp[x-1][y]==k) f=0;
if(mp[x][y-1]==k) f=0;
return f;
}

int cal(int x,int y)
{
if(x>N) return 1;
int res=(N-x)*M+M-y+2; ///剩余方格数+1 ;
for(int i=1;i<=K;i++) if(res/2<c[i]) return 0; ///剪枝,某种颜色剩余方格数>(剩余方格数+1)/2 肯定不对;
for(int i=1;i<=K;i++)
{
int f=0;
if(c[i]&&check(x,y,i)){
mp[x][y]=i; c[i]--;
if(y==M)  f=cal(x+1,1);
else      f=cal(x,y+1);
c[i]++;
}
if(f) return 1;
}
return 0;
}

int main()
{
int T,Case=1;
cin>>T;
while(T--)
{
scanf("%d%d%d",&N,&M,&K);
for(int i=1;i<=K;i++) scanf("%d",&c[i]);
printf("Case #%d:\n",Case++);

if(!cal(1,1)) { puts("NO"); continue; }
puts("YES");
for(int i=1;i<=N;i++)
for(int j=1;j<=M;j++)
printf("%d%c",mp[i][j],(j==M)?'\n':' ');
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: