您的位置:首页 > 其它

poj 1088 滑雪

2017-06-21 20:33 246 查看
滑雪

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 97550 Accepted: 37015
Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9


一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。
Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output

输出最长区域的长度。
Sample Input
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output
25
题目解析:
这是一个简单的DFS+dp题,首先我用DFS遍及所有点,然后用一个数组来储存每一次遍及的最长长度,最后用max函数来求出最长的长度。
代码:
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn=105;
int dir[4][2]= {{0,1},{1,0},{0,-1},{-1,0}};
int node[maxn][maxn],len[maxn][maxn];
int row,colum,Max,i,j;

int dp(int x,int y)
{
int tx,ty,ms;
ms=0;
if(len[x][y]!=0)
return len[x][y];
for(int k=0; k<=3; k++)
{
tx=dir[k][0]+x;
ty=dir[k][1]+y;
if(tx<0||ty<0||tx>row-1||ty>colum-1)
continue;
if(node[tx][ty]<node[x][y])
{
int s=dp(tx,ty);
ms=max(ms,s);
}
}
len[x][y]=ms+1;
return len[x][y];
}
int main()
{
while(cin>>row>>colum)
{
memset(node,0,sizeof(node));
memset(len,0,sizeof(len));
for(i=0; i<row; i++)
for(j=0; j<colum; j++)
cin>>node[i][j];
Max=-1;
for(i=0; i<row; i++)
for(j=0; j<colum; j++)
Max=max(Max,dp(i,j));
cout<<Max<<endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: