您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2017-06-18 18:51 363 查看
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2

刚开始第一个想到的是结构体......贼水
写到一半不想写了。分析一下数组就可以

刚开始没注意保留一位小数。。错了好多点

TIP:

输入 1 0 1        1 0 2

   结果是输出 1 0 3 应该是输出1 0 1啊。。我加上错的更多..

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
int main(){
double p[2000]={0};
int num1;
cin>>num1;
for(int i=0;i<num1;i++){
int a;
double b;
cin>>a>>b;
p[a]+=b;
}
cin>>num1;
for(int i=0;i<num1;i++){
int a;
double b;
cin>>a>>b;
p[a]+=b;
}
int sum=0;
for(int i=0;i<1010;i++){
if(p[i]!=0){
sum++;
}
}
cout<<sum;
for(int i=1010;i>=0;i--){
if(p[i]!=0){
cout<<" "<<i<<" ";
printf("%.1f",p[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: