您的位置:首页 > 其它

4.1.1--二分--Can you solve this equation?

2017-06-17 11:28 218 查看
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

[align=left]Output[/align]

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

[align=left]Sample Input[/align]

2
100
-4


[align=left]Sample Output[/align]

1.6152
No solution!


代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
#define exp 0.0000000001
int main()
{
int t,y;
scanf("%d",&t);
while(t--)
{
scanf("%d",&y);
if(y==-6) { printf("0.0000\n"); continue;}
double v,mid,l=0,r=100;
while((r-l)>exp)
{
mid=(r+l)/2;
v=8*pow(mid,4)+7*pow(mid,3)+2*pow(mid,2)+3*mid+6;
if(fabs(v-(double)y)<exp)
break;
else
{
if(v>y) r=mid;
else l=mid;
}
}
if((mid-0)>exp&&(100-mid)>=exp) printf("%.4lf\n",mid);
else printf("No solution!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: