您的位置:首页 > 其它

HDOJ 1115 Lifting the Stone (计算几何+多边形重心)

2017-06-15 21:57 274 查看
原题链接

一、题目描述

Problem Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly
and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly
to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 

 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed
by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the
neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 

 

Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal
point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 

 

Sample Input

2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11

 

Sample Output

0.00 0.00
6.00 6.00

二、题目分析

题目直截了当要求重心。所以,直接按照多边形的求解模版即可。不过,这题的OJ(如HDOJ)默认所有测试用例都是逆时针输入的,方便了求解面积,且为正向面积。减轻了很大一部分工作。直接依次算出每个子三角形的重心和面积即可。然后算出多边形的重心。

这里说的比较简陋,如果第一次接触计算几何。可以百度/goole一下,抓住向量叉积在计算几何中的应用。如判断线段相交、三角形面积、多边形面积、多边形重心、土包(凸包)。

如果,多边形的各顶点不是按照逆时针输入的,那么就不能按照下面的代码求解了。还需coder自己按照逆时针或顺时针重新排列各定点。

三、AC代码

#include<stdio.h>
#include<math.h>
#include<stdlib.h>

struct Point
{
double x, y;
};
int cas, n;
double Area(Point p0, Point p1, Point p2)
{
double area = 0;
area = (p1.x - p0.x)*(p2.y - p1.y) -(p2.x - p1.x)*(p1.y - p0.y); // cross products.
return area/2;
//return area; // actually, area should be divided by 2, but this problem, both is ok.
}
int main()
{
Point p0, p1, p2;
double sum_x, sum_y, sum_area, area;
scanf("%d", &cas);
while (cas--)
{
sum_x = sum_y = sum_area = 0;
scanf("%d", &n);
scanf("%lf%lf", &p0.x, &p0.y);
scanf("%lf%lf", &p1.x, &p1.y);
for (int i = 2; i < n; ++i)
{
scanf("%lf%lf", &p2.x, &p2.y);
area = Area(p0, p1, p2);
sum_area += area;
sum_x += (p0.x + p1.x + p2.x) * area;
sum_y += (p0.y + p1.y + p2.y) * area;
p1 = p2;
}
printf("%.2lf %.2lf\n", sum_x / sum_area / 3, sum_y / sum_area / 3);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息