您的位置:首页 > 其它

1004. Counting Leaves (30)

2017-06-15 21:27 381 查看

1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.

Sample Input

2 1

01 1 02

Sample Output

0 1

#include <iostream>

using namespace std;
int member[101][3] = {0}; // member二维数组存储信息,[x][0]表示x成员所在层数; [x][1]标识是否为叶子节点 1 标识叶子,0标识非叶子; [x][2]表示x成员的父节点
void Cal_level(int N, int M){
member[1][0] = 1;
for(int i = 0; i <= M; i++){
for(int j = 0; j <= N; j++){
int parent = member[j][2];
if(parent == -1)
continue;
if(member[parent][0] && !member[j][0]){
member[j][0] = member[parent][0] + 1;
}
}
}
}
void output(int N, int M){
int level = 1, num_Level_leaf = 0;
bool flag = false, level_flag = false;
for(int i = 0; i <= M; i++){
num_Level_leaf = 0;
level_flag = true;
for(int j = 0; j <= N; j++){
if(member[j][1] == 1 && member[j][0] == level)
num_Level_leaf++;
if(member[j][0] == level)
level_flag = false;
}

if(level_flag)
return;
if(!flag){
cout << num_Level_leaf;
flag = true;
}else
cout << " " << num_Level_leaf;
level++;
}
}
// 成员初始化,初始化时假设所有成员都为非叶子节点, -1表示无父节点
void init_member(){
for(int i = 0; i < 101; i++){
member[i][0] = 0;
member[i][1] = 1;
member[i][2] = -1;
}
}
int main(){
init_member();
int N, M;
cin >> N >> M;
for(int i = 0; i < M; i++){
int id, k, idk;
cin >> id >> k;
member[id][1] = 0;
for(int j = 0; j < k; j++){
cin >> idk;
member[idk][2] = id;
}
}
Cal_level(100, M);
if(M)  //单独解决输入样例: 1 0
output(100, M);
else
cout << 1;
cout << endl;
return 0;
}


其中测试数据中有 1 0 的测试数据输出应为 1. 需注意的是输入N M,由于N只表示树有N个节点,其中标识节点的数并非一定小于N,但在100以内,所以循环遍历是应遍历到100。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: