您的位置:首页 > 其它

Max Sum 最大连续子序列和

2017-06-13 20:23 288 查看
[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 
[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6

 

题意很清楚,就是最大子序列和,不过需要输出最大和区间的开始和结束,start为当前起始点
#include <iostream>
#include <cstdio>

using namespace std;

const int N = 1e5 + 5;
int a
;

int main()
{
int t,n;
cin >> t;
for(int k = 1; k <= t; k++)
{
cin >> n;
for(int i = 1; i <= n; i++)
scanf("%d",&a[i]);
int maxn = -1e8,sum = 0;    //maxn为当前最大值
int p,q,start = 1;           //起始点一开始为1,p为起始,q为结束
for(int i = 1; i <= n; i++)
{
sum += a[i];
if(sum > maxn)
{
maxn = sum;
p = start;
q = i;
}
if(sum < 0)
{
sum = 0;
start = i+1;         //更改起始点
}
}
printf("Case %d:\n",k);
printf("%d %d %d\n",maxn,p,q);
if(k < t)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: