您的位置:首页 > 其它

树状数组 stars

2017-06-13 09:47 197 查看
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount
of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated
by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and
so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

因为y是按升序给出 ,y相同的情况下 x升序 所以已经排好序了 只要把他们按顺序插入树状数组即可 树状数组的i代表x的坐标 这里有星星就加一 所以A[I]存的是这个坐标上星星的个数 统计在一个星星之前的星星数就query
因为求的是每个等级的星星数 所以用了 level数组
要注意树状数组不能有0 死循环

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=50005;
int a[maxn];
int n;
int lowbit(int i)
{
return i&(-i);
}
int update(int i,int x)
{
while(i<=maxn)
{
a[i]=a[i]+x;
i=i+lowbit(i);
}
//cout<<"1"<<endl;
}
int query(int i)
{
int sum=0;
while(i>0)
{
sum+=a[i];
i=i-lowbit(i);
//cout<<"q"<<" "<<i<<endl;
}
//cout<<"2"<<endl;
return sum;
}
int level[15005];
int main()
{

while(~scanf("%d",&n))
{
int x,y;
memset(level,0,sizeof(level));
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
{
scanf("%d%d",&x,&y);
x++;

level[query(x)]++;
//cout<<query(x)<<" "<<level[query(x)]<<endl;
update(x,1);
}
for(int i=0;i<n;i++)
printf("%d\n",level[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: