您的位置:首页 > 编程语言

九度oj-1036-old bill

2017-06-11 15:45 344 查看
题目描述:
    Among grandfather's papers a bill was found.

    72 turkeys $_679_

    The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are illegible. What are the two faded digits and what was the price of one turkey?

    We want to write a program that solves a general version of the above problem.

    N turkeys $_XYZ_

    The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkeys is an
integer number of dollars, and that all the

turkeys cost the same price.

    Given N, X, Y, and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two
faded digits and the maximum price per turkey for the turkeys.

输入:
    The first line of the input file contains an integer N (0<N<100), which represents the number of turkeys. In the following line, there are the three decimal digits X, Y, and Z., separated by a space, of the original price $_XYZ_.

输出:
    For each case, output the two faded digits and the maximum price per turkey for the turkeys.

样例输入:
72
6 7 9
5
2 3 7
78
0 0 5

样例输出:
3 2 511
9 5 18475
0


#include<stdio.h>

int main(){

int n;

int x,y,z;

while(scanf("%d",&n)!=EOF){
if(n==0) return 0;
scanf("%d %d %d",&x,&y,&z);
//printf("%d %d %d",x,y,z);
int temp=x*1000+y*100+z*10;
//printf("temp:%d",temp);
//int temp=m+k+l;
//printf("temp--%d\n");
int temp1=0,temp2=0;
int price=0,pi=0,pj=0;
int i,j;
int sum1,sum2;

for(i=1;i<10;i++){
for(j=0;j<9;j++){
sum1=i*10000+temp+j;
sum2=sum1+1;
//printf("sum1:%d,sum2:%d\n",sum1,sum2);
if(sum1%n==0) temp1=sum1/n;
if(sum2%n==0) temp2=sum2/n;
//printf("temp1:%d,temp2:%d\n\n",temp1,temp2);
if(temp1>temp2){
price=temp1;
pi=i;
pj=j;
}else if(temp1<temp2){
price=temp2;
pi=i;
pj=j+1;
}
temp1=temp2=0;
}
}
if(price==0)printf("0\n");
else
printf("%d %d %d\n",pi,pj,price);
}

return 0;
}

有一个很迷的问题,我开始把xyz的和算出来加起来放在temp里,测试结果一直是错误的,调试,发现每一步乘以1000,100,10的值都是对的,可是加起来就是一个神奇的数字。然后重新写了一遍,就没出错了。可能是我中间忽略哪里了吧。
后面判断temp1,temp2那er,我一开始想的是,temp1大于temp2,就把大的结果存在price,pi,pj里,后面就算相等应该也是重新存一遍这三个值,但结果也是错的。

因为后面temp1,temp2的值基本是0,所以就相等,就会把刚刚找到的price那三个值,改写了,导致结果出错。

下一题。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  编程 九度oj