您的位置:首页 > 其它

POJ The Balance —— 扩展欧几里得

2017-06-10 20:46 344 查看
题目链接:http://poj.org/problem?id=2142

The Balance

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 6783 Accepted: 2982
Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights
on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 

You are asked to help her by calculating how many weights are required. 



Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using
a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.
Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
You can measure dmg using x many amg weights and y many bmg weights. 

The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 

The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.
Sample Input
700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output
1 3
1 1
1 0
0 3
1 1
49 74
3333 1


代码如下:

#include <cstdio>
#include <iostream>
#define ms(a, b) memset((a), (b), sizeof(a))
using namespace std;
typedef long long LL;
const int INF = 2e9;
const LL LNF = 9e18;
const int mod = 1e9+7;
const int maxn = 2e5+10;

LL a,b,c;

LL exgcd(LL a, LL b, LL &x, LL &y)
{
if(b==0) {x = 1; y = 0; return a;}
LL g = exgcd(b, a%b, y, x);
y -= x*(a/b);
return g;
}

void solve()
{
LL x, y;
LL g = exgcd(a,b,x,y);
x *= c/g; y *= c/g;
a /= g; b /= g; c /= g; //等式两边要除以最大公约数,使得通式变为 x = x0+b*t, y = y0-a*t

LL vx, vy;
if(b>=a)
{
x = (x%b+b)%b;
y = (c-a*x)/b;
vx = x-b;
vy = (c-a*vx)/b;

if(x<0) x = -x;
if(y<0) y = -y;
if(vx<0) vx = -vx;
if(vy<0) vy = -vy;

if(x+y>vx+vy || (x+y==vx+vy && a*x+b*y>a*vx+b*vy)) x = vx, y = vy;
}

else
{
y = (y%a+a)%a;
x = (c-b*y)/a;
vy = y-a;
vx = (c-b*vy)/a;

if(x<0) x = -x;
if(y<0) y = -y;
if(vx<0) vx = -vx;
if(vy<0) vy = -vy;

if(x+y>vx+vy || (x+y==vx+vy && a*x+b*y>a*vx+b*vy)) x = vx, y = vy;
}

cout<<x<<' '<<y<<endl;
}

int main()
{
while(scanf("%lld%lld%lld",&a,&b,&c) && a && b && c)
{
solve();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: