您的位置:首页 > 编程语言 > C语言/C++

hackerrank>Dashboard>C++>STL>Vector-Erase

2017-06-10 10:17 525 查看

You are given a vector of
integers.Then you are given
queries.First query consists of
integer denoting the position in the vector which should be removed.Next query consists of

integers denoting the range of the positions in the vector that should be removed. The second query is performed on the updated vector which we get after performing the first query.

The following are some useful vector functions:

erase(int position):

Removes the element present at position.
Ex: v.erase(v.begin()+4); (erases the fifth element of the vector v)


erase(int start,int end):

Removes the elements in the range from start to end inclusive of the start and exclusive of the end.
Ex:v.erase(v.begin()+2,v.begin()+5);(erases all the elements from the third element to the fifth element.)


Input Format

The first line of the input contains an integer
.The next line contains
space separated integers(1-based index).The third line contai
4000
ns a single integer

,denoting the position of an element that should be removed from the vector.The fourth line contains two integers

and
denoting the range that should be erased from the vector inclusive of a and exclusive of b.

Constraints

Output Format

Print the size of the vector in the first line and the elements of the vector after the two erase operations in the second line separated by space.

Sample Input

6
1 4 6 2 8 9
2
2 4


Sample Output

3
1 8 9


Explanation

The first query is to erase the 2nd element in the vector, which is 4. Then, modifed vector is {1 6 2 8 9}, we want to remove the range of 2~4, which means the 2nd and 3rd elements should be removed. Then 6 and 2 in the modified vector are removed and we
finally get {1 8 9}

先删除所给下标的值,下标变动后,删除所给范围内下标的值,输出STL的size,与STL存储的值。

#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
#include <map>
#define MAX 1e9+8
using namespace std;
int main()
{
int N;
vector<int>vec1;
while(~scanf("%d",&N))
{
while(N--)
{
int t;
scanf("%d",&t);
vec1.push_back(t);
}
int n,m;
cin>>n;
vec1.erase(vec1.begin()+n-1);
vector<int>::iterator it;
cin>>n>>m;
m=m-n;
while(m--)
vec1.erase(vec1.begin()+n-1);
cout<<vec1.size()<<endl;
cout<<*vec1.begin();
for(it=vec1.begin()+1; it!=vec1.end(); it++)
cout<<' '<<*it;
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: