您的位置:首页 > 其它

hdu1856 More is better (并查集)

2017-06-07 11:09 579 查看


More is better

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 19011 Accepted Submission(s): 6998



Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8


Sample Output

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.


Author

lxlcrystal@TJU

Source

HDU 2007 Programming Contest - Final

Recommend

lcy | We have carefully selected several similar problems for you: 1102 1198 1162 1301 1829

Statistic | Submit | Discuss | Note

一个并查集 计算每一个集合的元素 找出元素最多的那个集合,输出元素的个数

输入n=0时也应该输出1

难点就在于,怎么计算集合的元素个数。

。事实上仅仅要在初始的时候每一个元素都初始为1。


然后合并集合的时候+1就好了

#include <stdio.h>
#include <string.h>
#define N 10000000+5
int fa
,stamp
;
int find(int x)
{
if(fa[x]!=x) fa[x]=find(fa[x]);
return fa[x];
}
void init()
{
for(int i=1;i<=N;i++)
fa[i]=i,stamp[i]=1;
}
int main()
{
int n,min,max;
while(~scanf("%d",&n))
{
init();
min=10000000+5,max=-1;
for(int i=0;i<n;i++)
{
int a,b;
scanf("%d %d",&a,&b);
a=find(a),b=find(b);
if(a!=b)
fa[a]=b,stamp[b]+=stamp[a];
if(a>max) max=a;
if(b>max) max=b;
if(a<min) min=a;
if(b<min) min=b;
}
int count=1;
for(int i=min;i<=max;i++)
{
if(stamp[i]>count)
count=stamp[i];
}
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: