您的位置:首页 > 其它

Zoj 3261 Connections in Galaxy War【逆序并查集】

2017-06-06 21:14 459 查看
Connections in Galaxy War
Time Limit: 3 Seconds     
Memory Limit: 32768 KB

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many
problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer
pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star
A directly or indirectly. In addition, this star should be more powerful than the star
A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star
A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains
N integers p0, p1, ... , pn-1 (0 <=
pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer
M (0 <= M <= 20000), that is the number of tunnels built before the war. Then
M lines follows. Each line has two integers a, b (0 <=
a, b <= N - 1, a != b), which means star
a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following
Q lines, each line will be written in one of next two formats.

"destroy a b" - the connection between star a and star
b was destroyed by the monsters. It's guaranteed that the connection between star
a and star b was available before the monsters' attack.

"query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output
"-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1


题目大意:

给你N个点,每个点都有对应的权值,已知有m条无向边,然后又Q个查询。

对应destroy 表示删除两个节点之间的边。

query x表示查询和x相连通的点中价值最高的点的编号,如果存在多个,输出编号最小的那个。

思路:

正向做肯定是相对比较难的。

正难则反,我们就反向思维去做即可。

将原图的m条边,如果在查询中没有destory掉的边先加入进去,然后我们逆向去合并查询即可。

合并遵循题目描述的规则。

数据可能有这种情况:

2

10 20

1

0 1

5

query 0

query 1

destroy 1 0

query 0

query 1

Ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<vector>
#include<map>
using namespace std;
struct node
{
char s[15];
int x,y;
}q[100020];
struct node2
{
int u,v;
}e[100020];
int ans[1050000];
int f[1500010];
int a[1500010];
int n,qq,m;
map<pair<int ,int >,int >s;
void init()
{
s.clear();
for(int i=0;i<n;i++)f[i]=i;
for(int i=0;i<n;i++)scanf("%d",&a[i]);
scanf("%d",&m);
for(int i=0;i<m;i++)
{
scanf("%d%d",&e[i].u,&e[i].v);
if(e[i].u>e[i].v)swap(e[i].u,e[i].v);
}
scanf("%d",&qq);
for(int i=0;i<qq;i++)
{
scanf("%s",q[i].s);
if(q[i].s[0]=='d')
{
scanf("%d%d",&q[i].x,&q[i].y);
if(q[i].x>q[i].y)swap(q[i].x,q[i].y);
pair<int ,int > tmp=make_pair(q[i].x,q[i].y);
s[tmp]=1;
}
else scanf("%d",&q[i].x);
}
}
int find(int a)
{
int r=a;
while(f[r]!=r)
r=f[r];
int i=a;
int j;
while(i!=r)
{
j=f[i];
f[i]=r;
i=j;
}
return r;
}
void merge(int aa,int bb)
{
int A=find(aa);
int B=find(bb);
if(A==B)return ;
if(a[A]>a[B])
{
f[B]=A;
}
else if(a[A]<a[B])
{
f[A]=B;
}
else
{
if(A<B)
{
f[B]=A;
}
else f[A]=B;
}
}
int main()
{
int kase=0;
while(~scanf("%d",&n))
{
if(kase>0)printf("\n");
kase++;
init();
for(int i=0;i<n;i++)f[i]=i;
for(int i=0;i<m;i++)
{
pair<int ,int >tmp=make_pair(e[i].u,e[i].v);
if(s[tmp]==1)continue;
merge(e[i].u,e[i].v);
}
for(int i=qq-1;i>=0;i--)
{
if(q[i].s[0]=='q')
{
if(a[find(q[i].x)]>a[q[i].x])ans[i]=find(q[i].x);
else ans[i]=-1;
}
else
{
merge(q[i].x,q[i].y);
}
}
for(int i=0;i<qq;i++)
{
if(q[i].s[0]=='q')printf("%d\n",ans[i]);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Zoj 3261