您的位置:首页 > 其它

hdu-1241 Oil Deposits

2017-06-06 20:31 323 查看


Oil Deposits


Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 12   Accepted Submission(s) : 10


Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid. 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following
this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

Sample Output

0
1
2
2

 

这道题意思就是   有一个 m*n 的油田 *代表没油 , @代表有油。  求 整个面积内 的 连通油田  有多少块 

比如说 测试数据 如图  就有2个 连通 油块

#include <iostream>
#include <string.h>
#include <queue>
#include <cstdio>
using namespace std;
char a[100][100];
int cx[8][2]={1,0,1,1,1,-1,0,1,0,-1,-1,0,-1,1,-1,-1}; //建立8个方向
int m,n;
int sum;
struct node
{
int x,y;
};
int pd(int x, int y) //判断是否满足条件
{
if (x>=0&&x<n&&y>=0&&y<m)
return true;
return false;
}
void bfs(int x, int y)
{
int i;
node now,next;
queue<node>q;
now.x = x;
now.y = y;
q.push(now);
while (!q.empty())
{
now = q.front();
q.pop();
for (i=0;i<8;i++)
{
next.x = now.x+cx[i][0];
next.y = now.y+cx[i][1];
if (pd(next.x,next.y)&&a[next.x][next.y]=='@')
{
a[next.x][next.y]='*';
q.push(next);
}
}
}

}
int main()
{
while (scanf("%d %d",&n,&m)&&m&&n)
{
//memset(a,'\0',sizeof(a));
int i,j;
sum=0;
for (i=0;i<n;i++)
{
scanf("%s",a[i]);
}
for (i=0;i<n;i++)
{
for (j=0;j<m;j++)
{
if (a[i][j]=='@')
{
sum++;
bfs(i,j);
}
}
}
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: