您的位置:首页 > 其它

A - Ancient Cipher UVA - 1339(古老的密码)

2017-06-05 21:46 441 查看
Ancient Roman empire had a strong government system with variousdepartments, including a secretservice department. Important documents were sent between provinces and the capital in encryptedform to prevent eavesdropping. The most popular ciphers in those times were so calledsubstitutioncipherandpermutation cipher.Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for allletters must be different. For some letters substitute letter may coincide with the original letter. Forexample, applying substitution cipher that changes all letters from ‘A’ to
Y' to the next ones in thealphabet, and changes
Z

’ to
A', to the message \VICTORIOUS" one gets the message \WJDUPSJPVT".

Permutation cipher applies some permutation to the letters of the message.  For example, ap-plying the permutation⟨2;1;5;4;3;7;6;10;9;8⟩to the message \

VICTORIOUS" one gets the message\IVOTCIRSUO".

It was quickly noticed that being applied separately, both substitution cipher and permutation

cipher were rather weak. But when being combined, they were strong enough for those times. Thus,

the most important messages were  rst encrypted using substitution cipher, and then the result was

encrypted using permutation cipher. Encrypting the message \

VICTORIOUS

" with the combination of

the ciphers described above one gets the message \

JWPUDJSTVP

".

Archeologists have recently found the message engraved on a stone plate. At the  rst glance it

seemed completely meaningless, so it was suggested that the message was encrypted with some substi-

tution and permutation ciphers. They have conjectured the possible text of the original message that

was encrypted, and now they want to check their conjecture. They need a computer program to do it,

so you have to write one.

Input

Input  le contains several test cases. Each of them consists of two lines. The  rst line contains the

message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so

the encrypted message contains only capital letters of the English alphabet. The second line contains

the original message that is conjectured to be encrypted in the message on the  rst line. It also contains

only capital letters of the English alphabet.

The lengths of both lines of the input  le are equal and do not exceed 100.

Output

For each test case, print one output line. Output


YES

’ if the message on the rst line of the input le

could be the result of encrypting the message on the second line, or `

NO

’ in the other case.

Sample Input

JWPUDJSTVP

VICTORIOUS

MAMA

ROME

HAHA

HEHE

AAA

AAA

NEERCISTHEBEST

SECRETMESSAGES

Sample Output

YES

NO

YES

YES

NO

题意:给定两组字符串,能否把其中一个字符串的各个字母重排,然后对26个字母做一个一一的映射(可以分别映射),使得两个字符串相同。

思路:使用两个数组记录26个字母分别出现的次数,排序后比较数字是否相同即可。

代码:

#include <iostream>
#include <cstdio>
#include <sstream>
#include <cstring>
#include <map>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#define LL long long
#define INF 0x3f3f3f3f
#define maxn 1024
#define Pair pair<int, int>
#define mem(a, b) memset(a, b, sizeof(a))
#define _  ios_base::sync_with_stdio(0),cin.tie(0)
//freopen("1.txt", "r", stdin);
using namespace std;
int dict[26],dict1[26];
int main()
{
char a[105],b[105];
while(cin>>a)
{
cin>>b;
memset(dict,0,sizeof(dict));
memset(dict1,0,sizeof(dict1));
int lena=strlen(a);
int lenb=strlen(b);
if(lena!=lenb)
{
cout<<"NO"<<endl;
continue;
}
for(int i=0;i<lena;i++)
{
dict[a[i]-'A']++;
dict1[b[i]-'A']++;
}
sort(dict,dict+26);
sort(dict1,dict1+26);
int flag=0;
for(int i=0;i<26;i++)
{
if(dict[i]!=dict1[i])
{
flag=1;
break;
}
}
if(flag)
{
cout<<"NO"<<endl;
continue;
}
cout<<"YES"<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: