您的位置:首页 > 其它

HDU - 1300 Pearls (dp)

2017-06-05 20:09 288 查看


Pearls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2666    Accepted Submission(s): 1316


Problem Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary
people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family. In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl
in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.

Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain
quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.

Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is
actually needed. No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the prices remain the same.

For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10 + (100+10)*20 = 2350 Euro.

Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.

The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested, or in a higher quality class, but not in a lower one.

 

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1 <= c <= 100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls
ai needed in a class (1 <= ai <= 1000). The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.

 

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

 

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

 

Sample Output

330
1344 

题意: 有n种珍珠,给出每种要买的数量和价格。现在有两种购买的方法,第一,如果单买一种,需要多买10个。第二 ,如果买连续的珍珠,也只需要多出10个,但是全部要按最高价格。

分析: 给出的顺序应该是已经按价格排了序的了,写的时候忘记排序也过了。 
分析达到当前状态 dp[i]。
有两种方式   1. 单独买第i个,
2.从j开始连续买到i  

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 100000000
int a[1100];
int b[1100];
int sum[1100];
int dp[1100];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n;
scanf("%d",&n);
sum[0]=0;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a[i],&b[i]);
sum[i]=sum[i-1]+a[i];
}
dp[0]=0;
for(int i=1;i<=n;i++)
{
dp[i]=dp[i-1]+(a[i]+10)*b[i];
for(int j=0;j<=i;j++)
{
dp[i]=min(dp[j]+(sum[i]-sum[j]+10)*b[i],dp[i]);
}
}
printf("%d\n",dp
);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: