您的位置:首页 > 其它

POJ1328解题报告

2017-06-05 16:23 316 查看
Radar Installation

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 40799Accepted: 9034
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover
d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 



 

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This
is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1

题意:假设海岸线是一条无限延伸的直线。陆地在海岸线的一侧,而海洋在另一侧。每一个小的岛屿是海洋上的一个点。雷达坐落于海岸线上,只能覆盖d距离,所以如果小岛能够被覆盖到的话,它们之间的距离最多为d。
题目要求计算出能够覆盖给出的所有岛屿的最少雷达数目。

我们假设岛屿i它的x坐标为island[i][0],而y坐标为island[i][1],那么有以下几种情况是invalide的,即输出-1的情况:
1.island[i][1]<0
2.abs(island[i][1])<d
3.d<0

其他的情况,应该就是正常情况,进入计算最小雷达数目。




如上图,红色的点为岛屿,那么能够覆盖到此岛屿的雷达所在的区间,应该就是以该岛屿为圆心的圆与x轴交点所在的区间。
这样,我们就可以计算出所有岛屿的雷达所在的区间,得到一个区间数组。
我们将这个数组按照区间左部分进行排序,那么重叠部分就表明这些岛屿的雷达可以共用一个。从而计算出最终解。

#include<stdio.h>
#include<limits.h>
#include<math.h>
#define MAXNUM 12701
//以岛屿为圆心,以d为半径做圆;得到各个圆与x轴相交的区间;去掉重复区间,即得到雷达数目
int calMin(int **island,int n,int d);
int main() {

int num = 0;
char s[10];

while(1){

num++;
int n,d,i;
scanf("%d%d",&n,&d);

if(n==0&&d==0){

break;
}

int **island = (int**)malloc(sizeof(int*)*n);
for(i=0;i<n;i++){

island[i] = (int*)malloc(sizeof(int)*2);
scanf("%d%d",&island[i][0],&island[i][1]);
}

//计算最少雷达个数
int min = calMin(island,n,d);
printf("Case %d: %d\n",num,min);

//读取空白行
gets(s);

free(island);
}

system("pause");
return 0;
}
int calMin(int **island,int n,int d){

double *arr = (double*)malloc(sizeof(double)*n*2);
int i,j;

for(i=0;i<n;i++){

if(island[i][1]<0||island[i][1]>d||d<0){

return -1;
}

//计算左右区间
if(abs(island[i][1]-d)<1e-6){

arr[2*i] = island[i][0];
arr[2*i+1] = island[i][0];
}else{

//计算
double x = sqrt(pow(d,2)-pow(island[i][1],2));

arr[2*i] = (double)island[i][0] - x;
arr[2*i+1] = (double)island[i][0] + x;
}
}

//排序
for(i=0;i<n-1;i++){

for(j=0;j<n-i-1;j++){

if(arr[2*j]>arr[2*(j+1)]){

double temp = arr[2*(j+1)];
arr[2*(j+1)] = arr[2*j];
arr[2*j] = temp;

temp = arr[2*(j+1)+1];
arr[2*(j+1)+1] = arr[2*j+1];
arr[2*j+1] = temp;
}
}
}

//去掉重合区间,得到雷达个数
int num = 0;
double right = -1;

for(i=0;i<n;i++){

if(i==0){

num++;
right = arr[2*i+1];
}else{

if(arr[2*i]<=right){

if(arr[2*i+1]<right){

right = arr[2*i+1];
}
continue;
}else{

num++;
right = arr[2*i+1];
}
}
}

return num;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj1328