您的位置:首页 > 其它

HDU - 1067 Gap

2017-06-04 13:53 363 查看


Gap

Problem Description

Let's play a card game called Gap. 

You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card.

First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout.



Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: "11" to the top row, "21" to the next, and so on.

Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout.



At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of "42" is "43", and "27" has no successor.

In the above layout, you can move "43" to the gap at the right of "42", or "36" to the gap at the right of "35". If you move "43", a new gap is generated to the right of "16". You cannot move any card to the right of a card of value 7, nor to the right of a
gap.

The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows.



Your task is to find the minimum number of moves to reach the goal layout.

 

Input

The input starts with a line containing the number of initial layouts that follow.

Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards.

 

Output

For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout,
produce "-1".

 

Sample Input

4

12 13 14 15 16 17 21
22 23 24 25 26 27 31
32 33 34 35 36 37 41
42 43 44 45 46 47 11

26 31 13 44 21 24 42
17 45 23 25 41 36 11
46 34 14 12 37 32 47
16 43 27 35 22 33 15

17 12 16 13 15 14 11
27 22 26 23 25 24 21
37 32 36 33 35 34 31
47 42 46 43 45 44 41

27 14 22 35 32 46 33
13 17 36 24 44 21 15
43 16 45 47 23 11 26
25 37 41 34 42 12 31

 

Sample Output

0
33
60
-1

 

解题思路:BFS加hash,这里我把整个地图映射成字符串,方便剪枝

#include<iostream>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<queue>
#include<set>
#include<stack>
#include<map>
using namespace std;

string layout[10][10];
map<string,int> vis;

struct point{
string str;
int step;
};

string makestr(){
string res="";
for(int i=1;i<=4;i++)
for(int j=1;j<=8;j++)
res+=layout[i][j];
return res;

}

int bfs(point start){
queue<point> que;
que.push(start);

vis[start.str]=1;

while(!que.empty()){

point tp=que.front();
que.pop();

int t=tp.step;
string str=tp.str;

if(str=="1112131415161700212223242526270031323334353637004142434445464700")
return t;

for(int i=0;i<str.length();i+=2){
if(str[i]=='0'){
char need1=str[i-2];
char need2=str[i-1];
if(need2!='7')
need2++;
else
continue;

if(need1=='0')
continue;

for(int j=0;j<str.length();j+=2)
if(str[j]==need1&&str[j+1]==need2){
point temp;
temp.str=str;
temp.str[i]=need1;
temp.str[i+1]=need2;
temp.str[j]='0';
temp.str[j+1]='0';
temp.step=t+1;
if(!vis[temp.str]){
vis[temp.str]=1;
que.push(temp);
}
break;
}
}
}

}

return -1;
}

int main(){

int t;
cin>>t;
while(t--){
vis.clear();
layout[1][1]="11";
layout[2][1]="21";
layout[3][1]="31";
layout[4][1]="41";

for(int i=1;i<=4;i++)
for(int j=2;j<=8;j++){
cin>>layout[i][j];
if(layout[i][j]=="11"||layout[i][j]=="21"||layout[i][j]=="31"||layout[i][j]=="41")
layout[i][j]="00";
}

point tt;
tt.step=0;
tt.str=makestr();

cout<<bfs(tt)<<endl;

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: