您的位置:首页 > 其它

HDU 2602 Bone Collector

2017-06-02 20:42 141 查看
出了套题,发现自己已经不会写背包了。。标程都拿不出手来。。。找些题练练手,特意开了个背包分类。


Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 61370    Accepted Submission(s): 25570


Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

 

这个题不需要什么题目大意和思路。。01背包裸题,不过我是第一次写一维的数组,没注意到第二层循环j需要反着从大往小跑。

附代码。

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstdlib>
#include<ctime>

using namespace std;

const int MAXN=4000;
int w[MAXN],v[MAXN];
int f[13000];

void work1(int n,int m)
{
memset(f,0,sizeof(f));
for (int i=1;i<=n;i++)
{
for (int j=m;j>=v[i];j--)
{
f[j]=max(f[j],f[j-v[i]]+w[i]);
}
}
printf("%d\n",f[m]);
}

int main()
{
int n,m,t;
scanf("%d",&t);
while (t)
{
scanf("%d%d",&n,&m);
for (int i=1;i<=n;i++)
{
scanf("%d",&w[i]);
}
for (int i=1;i<=n;i++)
{
scanf("%d",&v[i]);
}
t--;
work1(n,m);
}

return 0;
}


MAX随便设的不要在意这种细节。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: