您的位置:首页 > 其它

Problem D: 平面上的点和线——Point类、Line类 (V)

2017-06-01 23:40 489 查看

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。
根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序。
接口描述:
Point::show()方法:按格式输出Point对象。
Line::show()方法:按格式输出Line对象。
Line::SetLine(double, double, double, double)方法:设置Line对象起点的x,y坐标(第一个和第二参数)和终点的x,y坐标(第三个和第四个坐标),并返回本对象
Line::SetLine(const Point &, const Point &)方法:设置Line对象的起点(第一个参数)和终点(第二个坐标),并返回本对象
Line::SetLine(const Line&)方法:设置Line对象,复制参数的坐标,并返回本对象
Line::readLine()方法:从标准输入上读入坐标,格式见Sample

Input

输入的第一行为N,表示后面有N行测试样例。
每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

Output

输出为多行,每行为一条线段,起点坐标在前终点坐标在后,每个点的X坐标在前,Y坐标在后,Y坐标前面多输出一个空格,用括号包裹起来。输出格式见sample。
C语言的输入输出被禁用。

Sample Input

40,0 1,11,1 2,32,3 4,50,1 1,0

Sample Output

#include <iostream>
using namespace std;
class Point
{
public:
double x1,y1;
public:
Point(double xx1 = 0,double yy1 = 0)
{
x1 = xx1;
y1 = yy1;
cout<<"Point : ("<<x1<<", "<<y1<<") is created."<<endl;
}
void show()
{
cout<<"Point : ("<<x1<<", "<<y1<<")"<<endl;
}
~Point()
{
cout<<"Point : ("<<x1<<", "<<y1<<") is erased."<<endl;
}
Point (const Point& p)
{
x1 = p.x1;
y1 = p.y1;
cout<<"Point : ("<<x1<<", "<<y1<<") is copied."<<endl;
}
double getx()
{
return x1;

}
double gety()
{
return y1;
}
};
class Line
{
private:
Point x;
Point y;
public:
Line(double x1 = 0,double y1 = 0,double x2 = 0,double y2 = 0):x(x1,y1),y(x2,y2)
{
cout<<"Line : ("<<x.getx()<<", "<<x.gety()<<") to ("<<y.getx()<<", "<<y.gety()<<") is created."<<endl;
}
~Line()
{
cout<<"Line : ("<<x.getx()<<", "<<x.gety()<<") to ("<<y.getx()<<", "<<y.gety()<<") is erased."<<endl;
}
void show()
{
cout<<"Line : ("<<x.getx()<<", "<<x.gety()<<") to ("<<y.getx()<<", "<<y.gety()<<")"<<endl;

}
Line(const Point& p,const Point& q):x(p),y(q)
{

cout<<"Line : ("<<x.getx()<<", "<<x.gety()<<") to ("<<y.getx()<<", "<<y.gety()<<") is created."<<endl;

}
Line(const Line&l):x(l.x),y(l.y)
{
cout<<"Line : ("<<x.x1<<", "<<x.y1<<") to ("<<y.x1<<", "<<y.y1<<") is copied."<<endl;
}
void readLine()
{
char c;
int a1,b1,c1,z1;
cin>>x.x1>>c>>x.y1>>y.x1>>c>>y.y1;

}

Line& setLine(const Point &p,const Point &q)
{
x=p;
y=q;
return *this;
}
Line& setLine(const Line &p)
{
*this = p;
return *this;

}
// Line& setLine(double a,double b,double c,double d)
// {
// x.x1=a;
// x.y1=b;
// y.x1=c;
// y.y1=d;
// return *this;
// }
};

int main()
{
int num, i;
Point p(1, -2), q(2, -1), t;
t.show();
std::cin>>num;
Line line[num];
for(i = 0; i < num; i++)
{
line[i].readLine();
line[i].show();
}
Line l1(p, q), l2(p,t), l3(q,t), l4(l1);
l1.show();
l2.setLine(l1).show();
l3.show();
l4.setLine(t,q).show();
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: