您的位置:首页 > 编程语言 > Java开发

hdu 1219 AC Me (java版本)

2017-05-31 16:13 344 查看
AC Me

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18428 Accepted Submission(s): 7805

Problem Description

Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.

It’s really easy, isn’t it? So come on and AC ME.

Input

Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.

Note: the problem has multi-cases, and you may use “while(gets(buf)){…}” to process to the end of file.

Output

For each article, you have to tell how many times each letter appears. The output format is like “X:N”.

Output a blank line after each test case. More details in sample output.

Sample Input

hello, this is my first acm contest!

work hard for hdu acm.

Sample Output

a:1

b:0

c:2

d:0

e:2

f:1

g:0

h:2

i:3

j:0

k:0

l:2

m:2

n:1

o:2

p:0

q:0

r:1

s:4

t:4

u:0

v:0

w:0

x:0

y:1

z:0

a:2

b:0

c:1

d:2

e:0

f:1

g:0

h:2

i:0

j:0

k:1

l:0

m:1

n:0

o:2

p:0

q:0

r:3

s:0

t:0

u:1

v:0

w:1

x:0

y:0

z:0

水题:

AC代码

import java.util.Scanner;

public class Main{

/**
* @param args
*/
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner scan=new Scanner(System.in);
String str;
int a[]=new int[26];
while(scan.hasNext()){
str=scan.nextLine();
char b[]=str.toCharArray();
for(int i=0;i<26;i++){//初始化
a[i]=0;
}
for(int i=0;i<b.length;i++){
if(b[i]>='a'&&b[i]<='z'){
a[b[i]-'a']++;
}
}
for(int i=0;i<26;i++){
System.out.println((char)('a'+i)+":"+a[i]);
}
System.out.println();
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  java hdu1219 AC-ME 模拟