您的位置:首页 > 其它

HDU 2147 kiki's game(规律,博弈)

2017-05-30 23:21 369 查看

kiki's game

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 10763 Accepted Submission(s): 6526


[align=left]Problem Description[/align]

Recently kiki has nothing to do. While she is bored, an idea appears
in his mind, she just playes the checkerboard game.The size of the
chesserboard is n*m.First of all, a coin is placed in the top right
corner(1,m). Each time one people can move the coin into the left, the
underneath or the left-underneath blank space.The person who can't make a
move will lose the game. kiki plays it with ZZ.The game always starts
with kiki. If both play perfectly, who will win the game?

[align=left]Input[/align]
Input
contains multiple test cases. Each line contains two integer n, m
(0<n,m<=2000). The input is terminated when n=0 and m=0.

[align=left]Output[/align]
If kiki wins the game printf "Wonderful!", else "What a pity!".

[align=left]Sample Input[/align]

5 3

5 4

6 6

0 0

[align=left]Sample Output[/align]

What a pity!

Wonderful!

Wonderful!

[align=left]Author[/align]
月野兔

[align=left]Source[/align]
HDU 2007-11 Programming Contest
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2147
分析:推几组数据就可以猜出结论,(a*b)%2==0?"Wonderful!":"What a pity!"
下面给出AC代码:

#include <bits/stdc++.h>
using namespace std;
int main()
{
int a,b;
while(scanf("%d%d",&a,&b)&&(a&&b))
{
if(a*b%2==0)
printf("Wonderful!\n");
else printf("What a pity!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: