您的位置:首页 > 其它

HDU--ACMstep--Wooden Sticks

2017-05-30 21:30 330 查看
Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case,
and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

 

Output

The output should contain the minimum setup time in minutes, one per line.

 

Sample Input





4 9 5 2 2 1 3 5 1 4 



2 2 1 1 2 2 



1 3 2 2 3 1

 

Sample Output

2

1

3

 

Source

Asia 2001, Taejon (South Korea)

题意:如果一个木头的l和r都大于等于前一个就不花时间,否则时间+1,但第一根木头总是+1

心得体会:这个题做的也是很绝望,个人认为并不简单,而且题意理解的也不好,总之做的很伤感情的,参考的别人的题解

解题思路:首先按自定义排序后,从第一个没被用过的木头开始往后找,把能用的木头去掉,然后按顺序重新找没被用过的木头

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
int l,r;
};
bool comp (const node & obj1,const node & obj2) //首先按l排序,l相同按r排
{
if(obj1.l!=obj2.l) return obj1.l<obj2.l;
else return obj1.r<obj2.r;
}
bool ok[5001]; //记录是否被去除
int main()
{
int T,n,i,j,cnt,st;
node a[5001];
bool flag;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d%d",&a[i].l,&a[i].r);
sort(a,a+n,comp);
memset(ok,false,
4000
sizeof(ok));
ok[0]=true; st=cnt=0; //st指向第一个没有用过的木头
while(st<n)
{
cnt++;
for(i=st,j=st+1,flag=true;j<n;j++)
{
if(ok[j]) continue;
if(a[j].r>=a[i].r&&a[j].l>=a[i].l)
{
ok[j]=true;
i=j;  //理解不好这里是出问题的,题目里是连续的前后两个数比较,令i=j,然后j++,实现前后比较
}
else
{
if(flag)
{
st=j; //只按顺序找到头一个没用过的木头
flag=false;
}
}
}
if(flag) break; //已经都用过了
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: