您的位置:首页 > 编程语言 > C语言/C++

HDU - 1020

2017-05-30 17:29 183 查看
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string. 

2. If the length of the sub-string is 1, '1' should be ignored. 

InputThe first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000. 

OutputFor each test case, output the encoded string in a line. 

Sample Input
2
ABC
ABBCCC


Sample Output
ABC
A2B3C

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
char ch;
int T;
cin >> T;
getchar();
while(T--)
{
int f[1050] = {1}, index = 0;
char c[1050];
c[0] = getchar();
char initial = c[0];

while((ch = getchar()) != '\n')
{
if(initial == ch)
{
++f[index];
}
else
{
++index;
initial = ch;
c[index] = ch;
f[index] = 1;
}
}
for(int i = 0; i <= index; ++i)
{
if(f[i] > 1)
cout << f[i];
cout << c[i];
}
cout << endl;
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  c++ HDU