您的位置:首页 > 其它

04-树7 二叉搜索树的操作集   (30分)

2017-05-29 19:38 459 查看
本题要求实现给定二叉搜索树的5种常用操作。

函数接口定义:

BinTree Insert( BinTree BST, ElementType X );
BinTree Delete( BinTree BST, ElementType X );
Position Find( BinTree BST, ElementType X );
Position FindMin( BinTree BST );
Position FindMax( BinTree BST );

其中
BinTree
结构定义如下:

typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
ElementType Data;
BinTree Left;
BinTree Right;
};

函数
Insert
X
插入二叉搜索树
BST
并返回结果树的根结点指针;
函数
Delete
X
从二叉搜索树
BST
中删除,并返回结果树的根结点指针;如果
X
不在树中,则打印一行
Not Found
并返回原树的根结点指针;
函数
Find
在二叉搜索树
BST
中找到
X
,返回该结点的指针;如果找不到则返回空指针;
函数
FindMin
返回二叉搜索树
BST
中最小元结点的指针;
函数
FindMax
返回二叉搜索树
BST
中最大元结点的指针。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct TNode *Position; typedef Position BinTree; struct TNode{ ElementType Data; BinTree Left; BinTree Right; };
void PreorderTraversal( BinTree BT ); /* 先序遍历,由裁判实现,细节不表 */
void InorderTraversal( BinTree BT ); /* 中序遍历,由裁判实现,细节不表 */

BinTree Insert( BinTree BST, ElementType X ); BinTree Delete( BinTree BST, ElementType X ); Position Find( BinTree BST, ElementType X ); Position FindMin( BinTree BST ); Position FindMax( BinTree BST );
int main()
{
BinTree BST, MinP, MaxP, Tmp;
ElementType X;
int N, i;

BST = NULL;
scanf("%d", &N);
for ( i=0; i<N; i++ ) {
scanf("%d", &X);
BST = Insert(BST, X);
}
printf("Preorder:"); PreorderTraversal(BST); printf("\n");
MinP = FindMin(BST);
MaxP = FindMax(BST);
scanf("%d", &N);
for( i=0; i<N; i++ ) {
scanf("%d", &X);
Tmp = Find(BST, X);
if (Tmp == NULL) printf("%d is not found\n", X);
else {
printf("%d is found\n", Tmp->Data);
if (Tmp==MinP) printf("%d is the smallest key\n", Tmp->Data);
if (Tmp==MaxP) printf("%d is the largest key\n", Tmp->Data);
}
}
scanf("%d", &N);
for( i=0; i<N; i++ ) {
scanf("%d", &X);
BST = Delete(BST, X);
}
printf("Inorder:"); InorderTraversal(BST); printf("\n");

return 0;
}
/* 你的代码将被嵌在这里 */

输入样例:

10
5 8 6 2 4 1 0 10 9 7
5
6 3 10 0 5
5
5 7 0 10 3

输出样例:

Preorder: 5 2 1 0 4 8 6 7 10 9
6 is found
3 is not found
10 is found
10 is the largest key
0 is found
0 is the smallest key
5 is found
Not Found
Inorder: 1 2 4 6 8 9


基本操作,应熟练掌握

#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct TNode *Position;
typedef Position BinTree;
struct TNode{
ElementType Data;
BinTree Left;
BinTree Right
b6f5
;
};

void PreorderTraversal( BinTree BT ); /* 先序遍历,由裁判实现,细节不表 */
void InorderTraversal( BinTree BT ); /* 中序遍历,由裁判实现,细节不表 */
void PostorderTraversal( BinTree BT );

BinTree Insert( BinTree BST, ElementType X ); BinTree Delete( BinTree BST, ElementType X ); Position Find( BinTree BST, ElementType X ); Position FindMin( BinTree BST ); Position FindMax( BinTree BST );
int main()
{
BinTree BST, MinP, MaxP, Tmp;
ElementType X;
int N, i;

BST = NULL;
scanf("%d", &N);
for ( i=0; i<N; i++ ) {
scanf("%d", &X);
BST = Insert(BST, X);
}
printf("Preorder:"); PreorderTraversal(BST); printf("\n");
MinP = FindMin(BST);
MaxP = FindMax(BST);
scanf("%d", &N);
for( i=0; i<N; i++ ) {
scanf("%d", &X);
Tmp = Find(BST, X);
if (Tmp == NULL) printf("%d is not found\n", X);
else {
printf("%d is found\n", Tmp->Data);
if (Tmp==MinP) printf("%d is the smallest key\n", Tmp->Data);
if (Tmp==MaxP) printf("%d is the largest key\n", Tmp->Data);
}
}
scanf("%d", &N);
for( i=0; i<N; i++ ) {
scanf("%d", &X);
BST = Delete(BST, X);
}
printf("Inorder:"); InorderTraversal(BST); printf("\n");

system("pause");
return 0;
}
void PreorderTraversal( BinTree BT ){
if( BT ){
printf("%d ", BT->Data);
PreorderTraversal( BT->Left );
PreorderTraversal( BT->Right );
}
}
void InorderTraversal( BinTree BT ){
if( BT ){
InorderTraversal( BT->Left );
printf("%d ", BT->Data);
InorderTraversal( BT->Right );
}
}
void PostorderTraversal( BinTree BT ){
if( BT ){
PostorderTraversal( BT->Left );
PostorderTraversal( BT->Right );
printf("%d ", BT->Data);
}
}
BinTree Insert( BinTree BST, ElementType X ){
if( !BST ){
BST = (BinTree)malloc(sizeof(struct TNode));
BST->Data = X;
BST->Left = BST->Right = NULL;
}
else {
if( X < BST->Data ) BST->Left = Insert( BST->Left, X );
else if( X > BST->Data ) BST->Right = Insert( BST->Right, X );
//else if(X = BST->Data) do nothing
}
return BST;
}
BinTree Delete( BinTree BST, ElementType X ){
Position TMP;
if( !BST ) printf("Not Found\n");
else {
if( X < BST->Data ) BST->Left = Delete( BST->Left, X ); //从左子树递归删除
else if( X > BST->Data ) BST->Right = Delete( BST->Right, X ); //从右子树递归删除
else { //BST就是要删除的结点
if( BST->Left && BST->Right ){ //如果BST左右孩子都有
TMP = FindMin( BST->Right ); //从右子树中找到最小的结点来代替该结点
BST->Data = TMP->Data;
BST->Right = Delete( BST->Right, BST->Data ); //从右子树中把最小的结点删除
}
else {
TMP = BST;
if( !BST->Left ) //如果只有右结点,或者没有结点
BST = BST->Right;
else //只有左结点
BST = BST->Left;
free( TMP );
}
}
}
return BST;
}
Position Find( BinTree BST, ElementType X ){
if( !BST ) return NULL;
else if( X == BST->Data ) return BST;
else if( X > BST->Data ) return Find( BST->Right, X );
else if( X < BST->Data ) return Find( BST->Left, X );
return NULL;
}
//递归查找最小元素
Position FindMin( BinTree BST ){
if( !BST ) return NULL;
else if( !BST->Left ) return BST;
else if( BST->Left ) FindMin( BST->Left );
}
//非递归查找最大元素
Position FindMax( BinTree BST ){
if( BST )
while( BST->Right ) BST = BST->Right;
return BST;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: