您的位置:首页 > 其它

hduProblem-1016简单dfs

2017-05-29 11:44 113 查看


Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 49746    Accepted Submission(s): 21932


Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



 

Input

n (0 < n < 20).

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input

6
8

 

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

AC源码:

#include <iostream>
#include <vector>
using namespace std;

const int MAXN=25;
int flag[MAXN];
bool is_prime(int x)
{
for(int i=2;i*i<=x;++i)
if(x%i==0)
return false;
return true;
}
void dfs(int cur,int n,vector<int> &A)
{
if(cur==n)
{
if(is_prime(A[0]+A[cur-1]))
{
int flg=1;
for(int i=0;i<n;++i)
{
if(flg)
{
cout<<A[i];flg=0;
}
else
cout<<" "<<A[i];
}
cout<<endl;
}
return ;
}
for(int i=2;i<=n;++i)
{
if(flag[i]&&is_prime(A[cur-1]+i))
{
A.push_back(i);
flag[i]=0;
dfs(cur+1,n,A);
A.pop_back(); //恢复原样
flag[i]=1; //恢复原样
}
}
}

int main()
{
int n,kase=0;
while(cin>>n)
{
cout<<"Case "<<(++kase)<<":"<<endl;
for(int i=1;i<=n;++i)
flag[i]=1;
vector<int> A;
A.push_back(1);
dfs(1,n,A);
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: