您的位置:首页 > 其它

Pearls POJ 1260 DP

2017-05-29 09:19 387 查看
Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the
prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.
Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000).
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.
Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.
Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output

330
1344

Source

一开始错误是因为把这道题当作贪心来做。取的是第n个的最优解和第n-1的最优解相加然后求所有和,不是全局最优解。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<deque>
#include<iomanip>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<fstream>
#include<memory>
#include<list>
#include<string>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
#define MAXN 104
#define MOD 1000000
#define INF 1000000009
#define eps 0.00000001
/*
对于一个低品质珍珠只有两种优化方案:
1.不用贵的代替
2.全用贵的代替
因为如果部分用贵的代替,只是单纯增加价格!不会减少 10个低品质珍珠的固定消耗
分段! 求最优解!
*/
int T, n;
int dp[MAXN];
struct node
{
int val, num, sum;
}a[MAXN];
int main()
{
scanf("%d", &T);
while (T--)
{
scanf("%d", &n);
memset(dp, INF, sizeof(dp));
a[0].val = a[0].sum = a[0].num = 0;
for (int i = 1; i <= n; i++)
{
scanf("%d%d", &a[i].num, &a[i].val);
a[i].sum = a[i - 1].sum + a[i].num;
}
dp[0] = (a[0].num + 10)*a[0].val;
for (int i = 1; i <= n; i++)
{
dp[i] = (a[i].num + 10)*a[i].val + dp[i-1];
for (int j = 0; j < i; j++)
{
dp[i] = min(dp[i], dp[j] + (a[i].sum - a[j].sum + 10)*a[i].val);
}
}
printf("%d\n",dp
);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: