您的位置:首页 > 其它

Nearest Common Ancestors 【并查集找根节点】+【步近法在线求lca】or【LCA转RMQ】

2017-05-28 08:28 357 查看
Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:



In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge –the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2

16

1 14

8 5

10 16

5 9

4 6

8 4

4 10

1 13

6 15

10 11

6 7

10 2

16 3

8 1

16 12

16 7

5

2 3

3 4

3 1

1 5

3 5

Sample Output

4

3

给了一棵树,求lca ,首先要找到 根节点,根节点不同,求出的lca肯定不同。 还有一点就是由于题目中 只有一组询问lca。 这样的话,在线算法(步近)肯定比离线算法(LCA转RMQ)强。

代码

// 在线算法 (15ms)

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define MAXN 100000
#define MAXM 1000000+10
using namespace std;
struct Edge{
int from,to,nexts;
}edge[MAXN<<1];
int head[MAXN],top;
int  dis[MAXN];
int par[MAXN];
int n,m;
void addedge(int a,int b)
{
Edge e={a,b,head[a]};
edge[top]=e;head[a]=top++;
}
void init()
{
memset(head,-1,sizeof(head));
memset(par,-1,sizeof(par));
top=0;
}
void getmap()
{
int a,b;
while(m--)
{
scanf("%d%d",&a,&b);
par[b]=a;
addedge(a,b);
addedge(b,a);
}
}
void bfs(int st)
{
queue<int>Q;
memset(dis,-1,sizeof(dis));
memset(par,-1,sizeof(par));
dis[st]=0;Q.push(st);par[st]=-1;
while(!Q.empty())
{
int now=Q.front();Q.pop();
for(int i=head[now];i!=-1;i=edge[i].nexts)
{
int nexts=edge[i].to;
if(dis[nexts]==-1)
{
dis[nexts]=dis[now]+1;
par[nexts]=now;
Q.push(nexts);
}
}
}
}
int lca(int le,int ri)
{
while(dis[le]>dis[ri]) le=par[le];
while(dis[ri]>dis[le])  ri=par[ri];

while(le!=ri)
{
le=par[le];
ri=par[ri];
}

return le;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n); m=n-1;
init();
getmap();int st;
for(int i=1;i<=n;i++)
if(par[i]==-1) st=i;  //找到根节点
bfs(st);
int a,b;
scanf("%d%d",&a,&b);
printf("%d\n",lca(a,b));
}
return 0;
}


离线算法 LCA转RMQ (49ms)

代码

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define MAXN 10000+100
using namespace std;
struct Edge
{
int from, to, next;
};
Edge edge[MAXN<<1];
int head[MAXN], edgenum;
int vs[MAXN<<1], depth[MAXN<<1];
int id[MAXN];
int dfs_clock;
int pre[MAXN];//存储父节点
int N;
int root;//树的根
int find(int p)
{
int t;
int child = p;
while(p != pre[p])
p = pre[p];
while(child != p)
{
t = pre[p];
pre[child] = p;
child = t;
}
return p;
}
void init()
{
edgenum = 0;
memset(head, -1, sizeof(head));
for(int i = 1; i <= N; i++)
pre[i] = i;
}
void addEdge(int u, int v)
{
Edge E = {u, v, head[u]};
edge[edgenum] = E;
head[u] = edgenum++;
}
void getMap()
{
int a, b;
for(int i = 1; i < N; i++)
{
scanf("%d%d", &a, &b);
pre[b] = a;
//merge(a, b);
addEdge(a, b);
addEdge(b, a);
}
}
void DFS(int u, int fa, int d)
{
id[u] = dfs_clock;
vs[dfs_clock] = u;
depth[dfs_clock++] = d;
for(int i = head[u]; i != -1; i = edge[i].next)
{
int v = edge[i].to;
if(v == fa) continue;
DFS(v, u, d+1);
vs[dfs_clock] = u;
depth[dfs_clock++] = d;
}
}
void find_depth()
{
dfs_clock = 1;
memset(vs, 0, sizeof(vs));
memset(depth, 0, sizeof(depth));
memset(id, 0, sizeof(id));
for(int i = 1; i <= N; i++)
if(pre[i] == i) root = i;//找根节点
DFS(root, -1, 0);
}
int dp[MAXN<<1][30];
void RMQ_init(int NN)
{
for(int i = 1; i <= NN; i++)
dp[i][0] = i;
for(int j = 1; (1<<j) <= NN; j++)
{
for(int i = 1; i + (1<<j) - 1 <= NN; i++)
{
int a = dp[i][j-1];
int b = dp[i + (1<<(j-1))][j-1];
if(depth[a] < depth[b])
dp[i][j] = a;
else
dp[i][j] = b;
}
}
}
int query(int L, int R)
{
int k = 0;
while(1<<(k+1) <= R-L+1) k++;
int a = dp[L][k];
int b = dp[R-(1<<k)+1][k];
if(depth[a] < depth[b])
return a;
else
return b;
}
int LCA(int u, int v)
{
int x = id[u];
int y = id[v];
if(x < y)
return vs[query(x, y)];
else
return vs[query(y, x)];
}
void solve()
{
int a, b;
scanf("%d%d", &a, &b);
printf("%d\n", LCA(a, b));
}
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%d", &N);
init();
getMap();
find_depth();
RMQ_init(dfs_clock - 1);
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: