您的位置:首页 > 其它

POJ - 1007 - DNA Sorting

2017-05-27 20:28 357 查看
[align=center]DNA Sorting[/align]

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 101498 Accepted: 40675
Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four
letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions
(it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string
of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

排序
#include<iostream>
#include<algorithm>
using namespace std;
struct AP
{
int x;
char c[108];
}a[108];
bool compare(AP a,AP b);
int main()
{
int n,m;
while(cin>>n>>m!=NULL)
{
for(int i=0;i<m;i++)
{
cin>>a[i].c;
a[i].x=0;
for(int j=0;j<(n-1);j++)
for(int k=j+1;k<n;k++)
if(a[i].c[j]>a[i].c[k])
a[i].x++;
}
sort(a,a+m,compare);
for(int i=0;i<m;i++)
cout<<a[i].c<<endl;
}
return 0;
}
bool compare(AP a,AP b)
{
return a.x<b.x;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: