您的位置:首页 > 其它

杭电acm:HDU 2700 Parity

2017-05-26 14:18 447 查看


Parity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4762    Accepted Submission(s): 3579


[align=left]Problem Description[/align]
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of

0's does not affect the parity of a bit string.
 

[align=left]Input[/align]
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase
letter 'o'.

 

[align=left]Output[/align]
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the
letter was 'o').
 

[align=left]Sample Input[/align]

101e
010010o
1e
000e
110100101o
#

 

[align=left]Sample Output[/align]

1010
0100101
11
0000
1101001010

[align=left]题意:[/align][align=left]输入一串仅有0,1组成的数。数的最后以e或o结尾,以e结尾要求前面所有数中1的个数为偶数个,如果不是,将e改成1,输出改过后的数。如果是,将e改成0,输出改过后的数。以o结尾的数要求前面所有数中1的个数为奇数个,如果是,将o改成0,输出改过后的数。如果不是,将o改成1,输出改过后的数。[/align]
[align=left]思路:[/align][align=left]由题意可知e或o之前的数在输入和输出中是一样的,所以对于e或o之前的数只需要输入一个就输出一个即可。在输入e或o时进行特殊考虑即可。最后i注意以下输出格式,以及什么时候输入结束。[/align]
[align=left]代码:[/align]
#include<bits/stdc++.h>

using namespace std;

int main()
{
char c;
int count_1=0;
while(~scanf("%c",&c))
{
if(c=='#')
return 0;
if(c=='1')
{
count_1++;
cout << c;
}
if(c=='0')
cout << c;
if(c=='e')
{
if(count_1%2 == 0)
cout << '0' << endl;
else
cout << '1' << endl;
count_1=0;
}
if(c=='o')
{
if(count_1%2==0)
cout << '1' << endl;
else
cout << '0' << endl;
count_1=0;
}
}
return 0;
}
[align=left]
[/align][align=left]祝大家好运![/align][align=left]
[/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: