您的位置:首页 > 其它

HDU - 3974 I - Assign the task

2017-05-26 11:30 369 查看
Assign the task

Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2764 Accepted Submission(s): 1154

Problem Description

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody’s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

“C x” which means an inquiry for the current task of employee x

or

“T x y”which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1

5

4 3

3 2

1 3

5 2

5

C 3

T 2 1

C 3

T 3 2

C 3

Sample Output

Case #1:

-1

1

2

将树映射到区间,对于每个节点保存从自身到所有子节点的那个区间,然后单点查询。

#include<bits/stdc++.h>
using namespace std;
#define maxn 50505
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int n,z;
vector<int> v[maxn];
map<int,int> mp;
int lef[maxn],righ[maxn];
int tree[maxn<<2];

void build(int l,int r,int rt)
{
tree[rt]=-1;
if(l==r)
return;
else {
int m=(l+r)>>1;
build(lson);
build(rson);
}
}

void push_down(int rt)
{
tree[rt<<1]=tree[rt<<1|1]=tree[rt];
tree[rt]=-1;
}

void update(int L,int R,int c,int l,int r,int rt)
{
if(L<=l&&r<=R)
{
tree[rt]=c;
}
else {
if(tree[rt]!=-1)
push_down(rt);
int m=(l+r)>>1;
if(L<=m) update(L,R,c,lson);
if(m<R) update(L,R,c,rson);
}
}

int query(int p,int l,int r,int rt)
{
if(l==r)
{
return tree[rt];
}
if(tree[rt]!=-1)
push_down(rt);
int m=(l+r)>>1;
if(p<=m) return query(p,lson);
else return query(p,rson);
}

void dfs(int rt)
{
z++;
mp[rt]=z-1;
for(int i=0;i<v[rt].size();i++)
{
lef[v[rt][i]]=z;
dfs(v[rt][i]);
righ[v[rt][i]]=z-1;
}
}
int input[maxn];
int main()
{
int t,a,i,b,m;
int ci=0;
cin>>t;
while(t--)
{
cin>>n;
memset(input,0,sizeof(input));
for(int i=0;i<=n;i++)
v[i].clear();
for(i=0;i<n-1;i++)
{
cin>>a>>b;
input[a]=1;
v[b].push_back(a);
}
for(i=1;i<=n;i++)
if(!input[i]) break;
//将树转为区间
mp.clear();
z=1;
lef[i]=1;
dfs(i);
righ[i]=z-1;

char s[15];
printf("Case #%d:\n", ++ci);
cin>>m;
build(1,n,1);
while(m--) {
scanf("%s",s);
if(s[0]=='C')
{
scanf("%d",&a);
printf("%d\n",query(mp[a],1,n,1));
}
if(s[0]=='T')
{
scanf("%d%d",&a,&b);
update(lef[a],righ[a],b,1,n,1);
}
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: