您的位置:首页 > 其它

hdu 1019 Least Common Multiple

2017-05-25 15:24 351 查看

Least Common Multiple

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 52181    Accepted Submission(s): 19805
[/b]

[align=left]Problem Description[/align]
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

[align=left]Input[/align]
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ...
nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

[align=left]Output[/align]
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

[align=left]Sample Input[/align]

2
3 5 7 15
6 4 10296 936 1287 792 1

 

[align=left]Sample Output[/align]

105
10296
题目解析:这个题就是让求几个数的最小公倍数,首先我们要对数列进行排序,找到最大值,开始向上增大,每次增大最大的数,用循环就可以找到最小公倍数
代码:
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;

int main()
{
int t,s,n,i,j,m,a[5000];
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
for(i=a[n-1];;i+=a[n-1])
{
for(j=0;j<n-1;j++)
if(i%a[j]!=0)
break;
if(j==n-1)
break;
}
printf("%d\n",i);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: