您的位置:首页 > 编程语言 > C语言/C++

POJ 1002 487-3279

2017-05-25 12:18 405 查看
Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of
the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza
Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 

D, E, and F map to 3 

G, H, and I map to 4 

J, K, and L map to 5 

M, N, and O map to 6 

P, R, and S map to 7 

T, U, and V map to 8 

W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number
alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange
the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output
310-1010 2
487-3279 4
888-4567 3

Source

East Central North America 1999
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
map~

hash一下存进map里面,再记录一下出现次数就可以了,注意没有答案的时候要输出No duplicates.

输出的时候tot总是莫名其妙地被改,所以改了个顺序倒着输出了,如果哪位知道tot改动的原因,欢迎告诉我,感激不尽!

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<map>
using namespace std;

int n,num[100001],k[26]={2,2,2,3,3,3,4,4,4,5,5,5,6,6,6,7,0,7,7,8,8,8,9,9,9,0},l,now,cnt,jin[7],a[7],tot;
char s[12];

struct node{
int id,num;
}c[100001];

map<int,int> id;
map<int,int> nu;

bool operator < (node u,node v)
{
return u.id>v.id;
}

int main()
{
scanf("%d",&n);jin[0]=1;
for(int i=1;i<=6;i++) jin[i]=jin[i-1]*10;
for(int i=1;i<=n;i++)
{
scanf("%s",s);l=strlen(s);now=0;
for(int i=0;i<l;i++)
{
if(s[i]=='-') continue;
if(s[i]>='0' && s[i]<='9') now=now*10+s[i]-'0';
else now=now*10+k[s[i]-'A'];
}
if(id.count(now)) num[id[now]]++;
else id[now]=++cnt,num[cnt]=1,nu[cnt]=now;
}
for(int i=1;i<=cnt;i++)
if(num[i]>1) c[++tot]=(node){nu[i],num[i]};
sort(c+1,c+tot+1);
if(!tot) puts("No duplicates.");
for(int i=tot;i;i--)
{
now=c[i].id;
for(int j=7;j;j--)
{
a[j]=now/jin[j-1];now%=jin[j-1];
}
for(int j=7;j>=5;j--) printf("%d",a[j]);printf("-");
for(int j=4;j;j--) printf("%d",a[j]);printf(" ");printf("%d\n",c[i].num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ map