您的位置:首页 > 其它

Heavy Transportation(POJ-1797)

2017-05-23 21:51 323 查看
Description
Background

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed
on which all streets can carry the weight.

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's
place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers
specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer.
Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4


题意:有n个城市,m条道路,在每条道路上有一个承载量,现在要求从1到n城市最大承载量,而最大承载量就是从城市1到城市n所有通路上的最大承载量;

思路:迪杰斯特拉算法,稍微变形了一下;

ps:我用的是邻接表,所以要比矩阵的时间复杂度要小;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<utility>
#include<queue>
#include<vector>
#define maxn 1010
#define INF 0x3f3f3f3f
#define P pair<int,int>
using namespace std;
int m,n;
int T;
int a[maxn];
struct edge
{
int to,cost;
};
vector<edge>G[maxn];
void dijkstra(int s)
{
priority_queue<P,vector<P>,less<P> >que;  //less是把优先队列里的数从到小排,greater是从小到大排,默认是从大到小;
fill(a,a+n+5,0);
a[s]=INF;
que.push(P(INF,s));
while(!que.empty())
{
P p;
p=que.top();
que.pop();
int v=p.second;
if(v==n) break;
for(int i=0; i<G[v].size(); i++)
{
edge e=G[v][i];
if(a[e.to]<min(a[v],e.cost))
{
a[e.to]=min(a[v],e.cost);
que.push(P(a[e.to],e.to));
}
}
}
}
int main()
{
scanf("%d",&T);
for(int i=1; i<=T; i++)
{
scanf("%d%d",&n,&m);
for(int j=0; j<=n; j++)  //这个地方一定要有,不然就错了;
{
G[j].clear();
}
for(int j=0; j<m; j++)
{
int from,to,cost;
scanf("%d%d%d",&from,&to,&cost);
edge var;
var.to=to;
var.cost=cost;
G[from].push_back(var);
var.to=from;
G[to].push_back(var);
}
dijkstra(1);
printf("Scenario #%d:\n",i);
printf("%d\n\n",a
);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 最短路