您的位置:首页 > 其它

poj 2752 Seek the Name, Seek the Fame(KMP应用)

2017-05-22 21:58 344 查看

Seek the Name, Seek the Fame

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab

aaaaa

Sample Output

2 4 9 18

1 2 3 4 5

ps:首先明确next[i]的意义:前面长度为i的子串的【前缀和后缀的最大匹配长度】

然后通过求next函数,我们求得next[m-1](m为字符串的长度)的最大值q代表【长度为q的前缀】和【长度为q的后缀】是匹配的,也就是说整个串的最大前后缀匹配长度为q,

那么接下来只需要考虑长度小于q的前后缀匹配情况了,很明显我们只能在长度为q的前缀和长度为q的后缀中寻找,

又长度为q的前缀==长度为q的后缀,

因此只需要在长度为q的前缀中寻找当前的最大前后缀匹配长度,然后以此类推(具体详见代码)

代码:

4000

#include<stdio.h>
#include<string.h>

const int maxv=400010;
char w[maxv];
int nxt[maxv];
int a[maxv];
int cnt;

void get_next()
{
int m=strlen(w);
int q=0;
for(int i=1; i<m; ++i)
{
while(q>0&&w[i]!=w[q])
q=nxt[q-1];
if(w[i]==w[q])
++q;
nxt[i]=q;
}
int x=m;
cnt=0;
while(nxt[x-1])
{
a[cnt++]=nxt[x-1];
x=nxt[x-1];
}
}

int main()
{
while(~scanf("%s",w))
{
get_next();
for(int i=cnt-1;~i;--i)
printf("%d ",a[i]);
printf("%d\n",strlen(w));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: