您的位置:首页 > 其它

Cow Exhibition(POJ-2184)

2017-05-22 21:01 260 查看
Description
"Fat and docile, big and dumb, they look so stupid, they aren't much

fun..."

- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for
each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS
and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input
* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output
* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output
8

Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF

= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value

of TS+TF to 10, but the new value of TF would be negative, so it is not

allowed.

题意:一定数量的牛,主人带牛参加比赛,然后接下来输入每头牛的智商和情商 ,要求最后选出来的牛智商+情商最大,然后智商和情商都不能为负;

思路:01背包,用其中一个当体积,另一个当价值,如果体积为负就倒着装一遍;

#include<iostream>
#include<string.h>
#include<cstdio>
#define INF 0x3f3f3f3f
using namespace std;
int a[105],b[105];
int dp[210000];
int n;
int main()
{
scanf("%d",&n);
for(int i=1; i<=n; i++)
{
scanf("%d%d",&a[i],&b[i]);
}
for(int i=0; i<=210000; i++) dp[i]=-INF; //这里初始化一定要大;
dp[100000]=0;
for(int i=1; i<=n; i++) //如果a[i]>0,倒着,否则正着;
{
if(a[i]>=0)
{
for(int j=200000; j>=a[i]; j--) //为了不自己拿自己;
{
if(dp[j-a[i]]!=-INF)
{
dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
}
}
}
else
{
for(int j=0; j<=200000; j++)
{
if(dp[j-a[i]]!=-INF)
{
dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
}
}
}
}
int ans=0;
for(int i=100001; i<=200000; i++)
{
if(dp[i]!=-INF&&dp[i]>0)
{
ans=max(ans,(dp[i]+i-100000));
}
}
printf("%d\n",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 背包