您的位置:首页 > 其它

POJ2386:Lake Counting(dfs)

2017-05-22 16:22 295 查看
传送门:http://poj.org/problem?id=2386

Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34828 Accepted: 17285
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer
John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint
OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
Source
USACO 2004 November
翻译成中文:有一个大小为N×M的园子,雨后积了水。八连通被认为是连接在一起的。请求出园子里总共有多少水洼?
 简单的DFS问题,从任意w开始不停地把拎接部分用'.'代替,进行DFS,则所有w都被替换成.总共DFS次数就是答案了。

时间复杂度为O(N×M)。

#include <cstdio>
#include <iostream>
using namespace std;
const int MAXN=100;
const int MAXM=101;
char pic[MAXN][MAXM];
int N,M;
void input()
{
cin>>N>>M;
int i,j;
for(i=0;i<N;i++)
{
cin>>pic[i];
}
}
void dfs(int x,int y)
{
pic[x][y]='.';
for(int dx=-1;dx<=1;dx++)
{
for(int dy=-1;dy<=1;dy++)
{
int nx=x+dx;int ny=y+dy;
if(0<=nx&&nx<N&&0<=ny&&ny<M&&pic[nx][ny]=='W')dfs(nx,ny);
}
}
return;
}
void solve()
{
int res=0;
for(int i=0;i<N;i++)
{
for(int j=0;j<M;j++)
{
if(pic[i][j]=='W')
{
dfs(i,j);
res++;
}
}
}
printf("%d\n",res);
}
int main(void)
{
input ();
solve ();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM DFS